Problem
Storage Connector start; although, it is not possible to upload or download files using it. The following error message appears in the logs (xxxxxxx:
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Cause
The issue is observed when syncplicity.storage.type is set to "s3" and for some reason the bucket region (set in syncplicity.storage.s3.*.region) does not correspond to the actual bucket. There are two known reasons:
- Wrong region is accidentally configured.
- During a connector upgrade there was no connection to the AWS metadata service. "us-east-1" has been set as a region.
Solution
In the syncp-storage.yml change the syncplicity.storage.s3.*.region for the affected bucket to the one mentioned in the exception. Then, restart the service.