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Unable to upload and download files from S3 storage

Problem

Upload and download operations fail from all clients. The log file on the Storage Connector server indicates an exception error.

2016-09-28 11:14:01,493 [E] [2] - Upload Generic error  com.syncplicity.storage.client.StorageException: The request timestamp was outside the valid time window.at com.syncplicity.storage.client.atmos.AtmosClient$$anonfun$2.applyOrElse(AtmosClient.scala:113) ~[syncp-storage.syncp-storage-2.9.0.3.jar:2.9.0.3]


Cause

The time on the Storage Connector server is not synchronized with the S3 storage. Storage Connector verifies the uploads with a GET command, and the S3 storage requires the GET command in a specific time window. When the command arrives with a time stamp outside this window, the storage server suspects it as an attack and prevents upload/download operations.

Solution

Check the timeserver settings and verify that both Atmos server and Storage Connector are synchronized to the same time server. 

  • To update the time immediately, run Ntpdate pool.ntp.org.
  • To setup the time on the Storage Connector server manually, run the following commands.

    service syncp-storage stop
     date -s “28 Sep 2016 11:14:08“ (the time to match the Atmos sever)
     service syncp-storage start
     tail -f /var/log/syncp-storage/storage-YYYY-MM-DD.log
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